Google has recently updated its Maps App for Android to 4.1.0. Normally the update process in the market is straight forward, but some times it can get tricky, specially if you are using a custom ROM as most of the ROMs come with the Maps App pre-installed and that can make it difficult to update them.

When trying to update to the new version, if you get an error message like “Package file was not signed correctly.” or “Package was not signed correctly.”, then you need to uninstall the previous version of the App first and then install the new version. To uninstall the previous version, run this command from the computer:

adb uninstall com.google.android.apps.maps

After this install the new version from the Android Market.